signed

QiShunwang

“诚信为本、客户至上”

【错误记录】Flutter 报错 ( Android Studio 中 main.dart 左侧不显示设备栏 )

2021/3/21 0:30:56   来源:

文章目录

  • 一、报错信息
  • 二、解决方案





一、报错信息



为了解决 【错误记录】Flutter 构建报错 ( Because xxx requires SDK version >=2.12.0-0 <3.0.0, versio | Dart SDK 版本低 ) 中的问题 , 更新了 Flutter 与 Dart SDK ;

更新后出现该问题 , main.dart 栏左侧的设备栏不见了 , 右侧的设备栏不是 Flutter 运行的设备 ;

在这里插入图片描述

正常的情况是长这样的 :

在这里插入图片描述





二、解决方案



选择 File / Project Structure ;

在这里插入图片描述

在 Project Structure 对话框中的 Project 选项卡中配置 Android SDK ;

在这里插入图片描述

Library 选项卡的 Flutter 和 Dart SDK ;

在这里插入图片描述

Facts 选项卡的 Android 配置 , 参考 【错误记录】Android Studio 的 Flutter 代码界面没有 Logcat 面板 配置 ;

在这里插入图片描述

配置完毕 , 重启 Android Studio 即可解决该问题 ;

在这里插入图片描述