signed

QiShunwang

“诚信为本、客户至上”

安装keras

2021/5/14 21:11:21   来源:

一、问题引出

安装keras必须与tensorflow版本匹配才可以,我在tensorflow1.12上直接使用pip安装keras后,在使用过程中报如下错误。
在这里插入图片描述
由提示显示版本不兼容。

二、安装匹配

  1. 使用如下的代码查看自己的tensorflow版本.
import tensorflow as tf
print(tf.__version__)  #1.13.1

由运行的结果可知我的tensorflow版本是1.31.1,此时打开网址:https://docs.floydhub.com/guides/environments/查看对应的版本。
在这里插入图片描述
因此我需要安装2.0.6的Keras,则使用下面的命令先卸载再安装。

pip uninstall keras
pip install keras==2.0.6

到此,问题解决!